News:

  • February 01, 2023, 11:59:55 AM

Login with username, password and session length

Author Topic: Firmware Issue  (Read 22300 times)

OjaiBill

  • Newbie
  • *
  • Posts: 3
Firmware Issue
« on: September 06, 2007, 11:00:18 PM »
I have several GS-EDRV's connected to Durapulse inverters being controlled from a DL260 through a H2-ERM. When I load the firmware version 1.1.324 or 1.1.336 into the GS-EDRV, the Durapulse keypad begins to flash INVALID DATA. When I roll back to firmware to version 1.1.267 everything works fine. The later versions are supposed to be better optimized for a H2-ERM which is what I am using so I would like to use them if possible. Is there anything I may be able to change in order to get them to work?

MikeS

  • Host Moderator
  • Hero Member
  • *****
  • Posts: 253
    • Host Engineering, Inc.
Re: Firmware Issue
« Reply #1 on: September 07, 2007, 09:31:22 AM »
i want to make sure i know what hardware you have, so please bear with me.
what model of invertor do you have? gs1, gs2 or gs3?
what version of firmware is in the invertor? is this a relatively new version?

the reason i ask is that the most recent change to the gs-edrv firmware is a result of a firmware change in the gs1 and gs2 drive. it was exhibiting a similar problem in the drives display.
Good design costs a lot. Bad design costs even more.

MikeS

  • Host Moderator
  • Hero Member
  • *****
  • Posts: 253
    • Host Engineering, Inc.
Re: Firmware Issue
« Reply #2 on: September 07, 2007, 01:30:18 PM »
after talking to the automationdirect.com guys, their said to make sure that to send the reference command as a decimal with an implied decimal point (for example sending 245 decimal and the drive will run at 24.5 Hz).

also read the "Present Output frequency"  as decimal (you should see 245 in data view).
Good design costs a lot. Bad design costs even more.

OjaiBill

  • Newbie
  • *
  • Posts: 3
Re: Firmware Issue
« Reply #3 on: September 07, 2007, 11:13:07 PM »
The drives are all GS3 Durapulse inverters. I am not sure of the firmware version of the inverter but I believe they were bought about a year ago. I can determine the versions next week and let you know. Also, I did check to ensure that there were only zeroes in the PLC registers that the H2-ERM was programmed to use for the GS-EDRV transfers so I do not think it is likely to be a bad number or a decimal place issue.

davidbgtx

  • Hero Member
  • *****
  • Posts: 215
  • Host be the Most
Re: Firmware Issue
« Reply #4 on: December 13, 2007, 09:39:59 PM »
I have this same exact problem, with the same drive. I  also had to revert to 1.1.267. Also netedit 3 live update does not download 1.1.339

MikeS

  • Host Moderator
  • Hero Member
  • *****
  • Posts: 253
    • Host Engineering, Inc.
Re: Firmware Issue
« Reply #5 on: December 14, 2007, 09:05:36 AM »
(as of 9:04 am, 12/14/07) gs-edrv firmware v1.1.339 is now available through netedit3's liveupdate.
Good design costs a lot. Bad design costs even more.

davidbgtx

  • Hero Member
  • *****
  • Posts: 215
  • Host be the Most
Re: Firmware Issue
« Reply #6 on: September 11, 2008, 01:09:27 PM »
Just added another GS-EDRV with firmware 1.1.339, still have to revert to 1.1.267 firmware to prevent the invalid data flashing.

OjaiBill

  • Newbie
  • *
  • Posts: 3
Re: Firmware Issue
« Reply #7 on: October 07, 2008, 11:30:23 PM »
Yeah, not really sure what the deal is with the firmware issues on the GS-EDRV's. I probably have about 20-25 drives in my facilities with GS-EDRV's but I have to load 1.1.267 into about half of them, even newer ones, in order to get rid of the INVALID DATA on the keypad. Not a big deal since 1.1.267 seems to work just fine.

Greg

  • HostTech
  • Host Moderator
  • Hero Member
  • *****
  • Posts: 660
  • Hmmm...
    • Host Engineering, Inc.
Re: Firmware Issue
« Reply #8 on: October 08, 2008, 10:54:33 AM »
davidbgtx & OjaiBill,

Does this FAQ help? Or cover the bases?

http://www.hosteng.com/FAQFiles/EDRV.htm#FAQ0016
There are two types of people in the world; those that can extrapolate from incomplete data sets.

davidbgtx

  • Hero Member
  • *****
  • Posts: 215
  • Host be the Most
Re: Firmware Issue
« Reply #9 on: October 14, 2008, 12:58:02 PM »
The last time I tried was with a GS3 with Firmware v1.04 and GS-EDRV firmware v1.1.339
Only have to revert back to v1.1.267 not all the way to v1.1.109
Maybe it's only when using a WinPLC with ERM issue?

davidbgtx

  • Hero Member
  • *****
  • Posts: 215
  • Host be the Most
Re: Firmware Issue
« Reply #10 on: February 04, 2009, 07:27:47 AM »
Is there any chance this issue will be resolved? Just installed another, tried latest firmware, and still have to revert back to 1.1.267 to keep from getting the flasing invalid data on the drive.

Greg

  • HostTech
  • Host Moderator
  • Hero Member
  • *****
  • Posts: 660
  • Hmmm...
    • Host Engineering, Inc.
Re: Firmware Issue
« Reply #11 on: February 04, 2009, 08:41:08 AM »
Sorry davidbgtx, this is not something we can fix. Certain older GS3 firmwares and GS-EDRV firmwares are incompatible. We can't control the GS3 drive firmware feature update ourselves, we only control the EDRV firmware and keep it compatible with GS3 drive development. The EDRV firmware would have to be able to sense the older GS3 drive firmware revision in order to "act" properly. This feature was not available on older GS3 firmware versions (it is on newer ones).

The good thing is that the latest GS3 firmware does work with the latest GS-EDRV firmware. Thus, as indicated in the EDRV FAQ0016 there are still only 2 solutions:

(1) Upgrade the GS3 drive firmware to v1.04 or later and the GS-EDRV to v1.1.339 or later, or...
(2) Downgrade the GS-EDRV firmware to v1.1.109 or earlier.

Sorry...  :-\
There are two types of people in the world; those that can extrapolate from incomplete data sets.

davidbgtx

  • Hero Member
  • *****
  • Posts: 215
  • Host be the Most
Re: Firmware Issue
« Reply #12 on: February 16, 2009, 01:53:17 PM »
If you read my post from October 14, 2008, 12:58:02 pm Posted by: davidbgtx, you see where I tried with Drive firmware 1.04 and GS-EDRV firmware 1.1.339, still doesn't work, smae problem.

Greg

  • HostTech
  • Host Moderator
  • Hero Member
  • *****
  • Posts: 660
  • Hmmm...
    • Host Engineering, Inc.
Re: Firmware Issue
« Reply #13 on: February 20, 2009, 11:34:02 AM »
davidbgtx, I'm sorry, but I cannot duplicate the failure you mention, instead it works just like I've indicated in the FAQ above.  :-\ Therefore, are you sure you are not actually writing a value that is out of range somewhere? I even spoke to the AutomationDirect technicians about this issue, and they indicated the same. So, I am very confused by this ???.
There are two types of people in the world; those that can extrapolate from incomplete data sets.