I have a DoMore PLC running 2.9.7, and one of the functions it performs is an HTTP request with subsequent JSON parse to api.openweathermap.org. It runs smoothly for months on end, however if the network goes down for a length of time (usually over an hour) it will sometimes stop running. It's fixed by a reboot of the PLC* (after the network issue is resolved).
Today, this happened again and I did a bit of troubleshooting before rebooting the unit. The HTTPCMD is setting the error bit with a response status code of 0 and empty strings for the response text / header / body. Additionally, the PLC status will ocassionally flash yellow and it shows "DNS server was unable to find address...in HTTPCMD at Weather_JSON_SG at 29".
When I use Tools --> Lookup IP adress, it correctly resolves api.openweathermap.org and it's possible to browse to the adress on a computer and receive an appropriate JSON response.
Any suggestions on how I can troubleshoot this / what might be happening?
* It actually requires a hard / physical power cycle to correct the problem. Re-initializing the PLC I/O doesn't work, and even using the REBOOT command (set by a CNR bit) doesn't work - only a physical power cycle.
Thanks.