If you are restarting mosquitto, it could be their bug. What I saw in their verbose dump was them publish to the PLC (it was subscribed to the same topic I'm publishing) in response to the PLC publishing to mosquitto, but the log didn't show mosquitto ever receiving the publish from the PLC to start with. That can't be, because they wouldn't publish multiple times due to a single subscription, and it was showing more than one. It appears that they are getting tripped up during a pregnant moment at startup.
When it works correctly, I see both the publish from the PLC to mosquitto, and mosquito publishing back to the PLC's subscription. When it fails, I just see the effect, and not the cause.
If you aren't already, run mosquitto with -v.