News:

  • October 16, 2021, 07:49:35 AM

Login with username, password and session length

Author Topic: H2-EBC100 IPX fails in NetEdit3  (Read 8665 times)

dandro

  • Newbie
  • *
  • Posts: 1
H2-EBC100 IPX fails in NetEdit3
« on: September 22, 2015, 10:20:07 AM »
I am putting together a brand new system. When I try to connect to my H2-EBC100 with NetEdit3 using the IXP/SPX protocol I get a dialog saying "A critical failure occurred in NetEdit and execution details were written to C:\HAPTools\NetEdit3_3_1_2.dmp. I can not talk to the EBC with Think & Do either. I get a network error. I can talk to the EBC with TCP/IP but Think & Do still errors using that protocol too.

BobO

  • Host Moderator
  • Hero Member
  • *****
  • Posts: 5485
  • Yes Pinky, Do-more will control the world!
Re: H2-EBC100 IPX fails in NetEdit3
« Reply #1 on: September 22, 2015, 10:53:39 AM »
Definitely shouldn't crash, but IPX may not be supported on the OS. XP was pretty much the last OS that shipped IPX.
"It has recently come to our attention that users spend 95% of their time using 5% of the available features. That might be relevant." -BobO

Mike Nash

  • Hero Member
  • *****
  • Posts: 624
Re: H2-EBC100 IPX fails in NetEdit3
« Reply #2 on: October 01, 2015, 11:42:53 AM »
Netedit 3 crashes on IPX on Windows XP too, two different machines. I am running version 3.14 (which doesn't exist yet per your download page?) I don't recall ever having this issue with previous versions though. The files mine are creating are "NetEdit3__3_1_4__20151001_152110.dmp" with various times in the name.

I have one NIC with multiple IP addresses. Netedit will find the H2-DM1E and an Ecom100 in a D0-06 as long as I select TCP/IP and any adapter (IP address) except Default. IPX crashes every time. I do have NWLink IPX/SPX/NetBIOS Compatible blah-blah-blah installed and enabled.


Mike Nash

  • Hero Member
  • *****
  • Posts: 624
Re: H2-EBC100 IPX fails in NetEdit3
« Reply #3 on: October 06, 2015, 03:08:31 PM »
Well... Now on this XP computer with NetEdit 3.14 it is the TCP/IP that is crashing and IPX works fine. The TCP/IP crash occurs immediately after selecting any adapter except Default. Default does not find any ECOM100s, IPX doesn't allow adapter selection.

Any advice on this weird bipolar behavior?

BobO

  • Host Moderator
  • Hero Member
  • *****
  • Posts: 5485
  • Yes Pinky, Do-more will control the world!
Re: H2-EBC100 IPX fails in NetEdit3
« Reply #4 on: October 06, 2015, 10:06:19 PM »
Lithium?

j/k...I'll look into this shortly. We've seen some weirdness, but it was limited to one VM and we convinced ourselves it wasn't real. Apparently it is.
"It has recently come to our attention that users spend 95% of their time using 5% of the available features. That might be relevant." -BobO

BobO

  • Host Moderator
  • Hero Member
  • *****
  • Posts: 5485
  • Yes Pinky, Do-more will control the world!
Re: H2-EBC100 IPX fails in NetEdit3
« Reply #5 on: October 07, 2015, 08:53:30 PM »
I have been able to crash it reliably in an XP VM with IPX installed. The actual crash makes *zero* sense, it's just an attribute query of the list control, but I have also been able to make it not crash by shuffling things around or changing a compiler option. It honestly feels like a compiler optimization issue, but I am very reluctant to claim that. I want to play with it a bit more and see if I can better understand whether what I have is a legit fix. If so, we'll get something posted by early next week.
"It has recently come to our attention that users spend 95% of their time using 5% of the available features. That might be relevant." -BobO

BobO

  • Host Moderator
  • Hero Member
  • *****
  • Posts: 5485
  • Yes Pinky, Do-more will control the world!
Re: H2-EBC100 IPX fails in NetEdit3
« Reply #6 on: October 08, 2015, 11:27:47 AM »
Ok...as expected, it wasn't a compiler issue. I am certain I know the issue and the issue is fixed. We will be publishing a new NetEdit as quickly as we can.

Oddly, it appears that it has been broken forever, but prior builds didn't expose it. It's random and could also be very machine/OS specific, which might explain why I hadn't seen it on my Win7 system, but it died easily on an XP VM.
"It has recently come to our attention that users spend 95% of their time using 5% of the available features. That might be relevant." -BobO

Mike Nash

  • Hero Member
  • *****
  • Posts: 624
Re: H2-EBC100 IPX fails in NetEdit3
« Reply #7 on: October 08, 2015, 01:12:26 PM »
Well I totally can agree with the randomness. I tried my machine at home, no crashes (but no PLCs on network.) I tried this one at work again just now and it is back to IPX crashing and TCP/IP works. Default sees nothing and any of the fixed addresses on the one NIC all work.

Almost like a day of the week type thing ;)  All 3 machines have v3.14 and I have never seen this in previous versions.

BobO

  • Host Moderator
  • Hero Member
  • *****
  • Posts: 5485
  • Yes Pinky, Do-more will control the world!
Re: H2-EBC100 IPX fails in NetEdit3
« Reply #8 on: October 08, 2015, 02:19:00 PM »
Well I totally can agree with the randomness. I tried my machine at home, no crashes (but no PLCs on network.) I tried this one at work again just now and it is back to IPX crashing and TCP/IP works. Default sees nothing and any of the fixed addresses on the one NIC all work.

Almost like a day of the week type thing ;)  All 3 machines have v3.14 and I have never seen this in previous versions.

If a particular randomized bit ends up true, it'll crash. It has been that way since the very earliest versions, but apparently has tended to be false in most cases. The new version probably shifted the stack utilization enough to put true into that bit some percentage of the time. We still find stuff in software we wrote 20 years ago and we always say something like "Wow, that's always been broke. Why haven't we seen it?" And such is this...
"It has recently come to our attention that users spend 95% of their time using 5% of the available features. That might be relevant." -BobO

Mike Nash

  • Hero Member
  • *****
  • Posts: 624
Re: H2-EBC100 IPX fails in NetEdit3
« Reply #9 on: October 19, 2015, 12:10:44 PM »
Ok...as expected, it wasn't a compiler issue. I am certain I know the issue and the issue is fixed. We will be publishing a new NetEdit as quickly as we can.

Oddly, it appears that it has been broken forever, but prior builds didn't expose it. It's random and could also be very machine/OS specific, which might explain why I hadn't seen it on my Win7 system, but it died easily on an XP VM.

Any time frame as to when I should be looking for this update?

And where will it be when it is ready? I get confused as to where and how to look for some of these type things.

BobO

  • Host Moderator
  • Hero Member
  • *****
  • Posts: 5485
  • Yes Pinky, Do-more will control the world!
Re: H2-EBC100 IPX fails in NetEdit3
« Reply #10 on: October 19, 2015, 05:34:19 PM »
"It has recently come to our attention that users spend 95% of their time using 5% of the available features. That might be relevant." -BobO

Mike Nash

  • Hero Member
  • *****
  • Posts: 624
Re: H2-EBC100 IPX fails in NetEdit3
« Reply #11 on: October 19, 2015, 06:38:17 PM »
Already published.

http://www.hosteng.com/SW-Products/SP_Demo_Utilites.htm#NetEdit3

Super! (See I didn't check recently enough or in the right place or something.)

Must be a lot of demand, it took over 20 minutes for the 5.4MB file to download.  :o

I have installed it and no crashes. I am also able to connect to an H0-ECOM100/D0-06 and an H2-DM1E over a VPN using Connect Single and IP addresses.

I'm happy.  ;D

BobO

  • Host Moderator
  • Hero Member
  • *****
  • Posts: 5485
  • Yes Pinky, Do-more will control the world!
Re: H2-EBC100 IPX fails in NetEdit3
« Reply #12 on: October 19, 2015, 06:57:23 PM »
Not sure about the slow download, but I'm happy that you are!
"It has recently come to our attention that users spend 95% of their time using 5% of the available features. That might be relevant." -BobO