News:

  • October 16, 2021, 06:56:09 AM

Login with username, password and session length

Author Topic: T1H-EBC100 and Visual Basic 6  (Read 6870 times)

Gyzmologist

  • Newbie
  • *
  • Posts: 1
T1H-EBC100 and Visual Basic 6
« on: March 21, 2019, 02:51:58 PM »
Software that we have developed and has been in production is now failing when running in VB6; previously it worked fine. Stand alone EXE files run fine. When trying to connect to the EBC100 in VB6 I get error code 10047, yet I can ping it with no errors. I updated the firmware in the EBC100 and no change.

This is an application that is currently running on the machine, I'm just trying to update it. The machine in manufacturing is running fine at the moment.

I've tried running in Windows 7 as well as 10, and get the same error, 10047.

I realize VB6 is obsolete, but we have 20+ machines running with it. If I have to convert them to .NET I will, but that would take a while.

Has anyone else run into and solved this issue?

TIA!
Gyz

BobO

  • Host Moderator
  • Hero Member
  • *****
  • Posts: 5485
  • Yes Pinky, Do-more will control the world!
Re: T1H-EBC100 and Visual Basic 6
« Reply #1 on: March 21, 2019, 02:58:36 PM »
What transport protocol are you using, IPX or IP?
"It has recently come to our attention that users spend 95% of their time using 5% of the available features. That might be relevant." -BobO

ADC Product Engineer

  • Hero Member
  • *****
  • Posts: 260
  • What are we going to do tonight Brain?
Re: T1H-EBC100 and Visual Basic 6
« Reply #2 on: March 22, 2019, 01:12:01 PM »
To tag onto BobO's question; IPX was obsoleted by Microsoft in Windows 7.