News:

  • October 16, 2021, 06:54:54 AM

Login with username, password and session length

Author Topic: Cannot update Bootloader with NetEdit3  (Read 10755 times)

hirzel

  • Newbie
  • *
  • Posts: 8
Cannot update Bootloader with NetEdit3
« on: August 12, 2014, 11:25:40 AM »
I have an older H4EBC. A couple times a year, it locks up the inputs and I need to power cycle everything.

I installed NetEdit3 and was going to update the Bootloader and Firmware.

When I try and update the bootloader, I get a message screen that says:

"Replace Bootloader version 2.1.47 with version 3.0.154"

I say yes,  then about a minute later I get a message that says:

"ERROR -2 from DownloadBinFile!"

Should I upgrade the firmware first, then go back and try the boot loader again???

Ideas??



I replaced the EBC with my spare and this fixed my problems and it has the latest firmware an bootloader.

John





hirzel

  • Newbie
  • *
  • Posts: 8
Re: Cannot update Bootloader with NetEdit3
« Reply #1 on: August 12, 2014, 01:07:17 PM »
UPDATE_

I tried to do the Firmware update first.  no good.  Same thing.

The message "Waiting for booter"  appears for about a minute,  then I get the "ERROR -2 from DownloadBinFile!" message.

Greg

  • HostTech
  • Host Moderator
  • Hero Member
  • *****
  • Posts: 604
  • Hmmm...
    • Host Engineering, Inc.
Re: Cannot update Bootloader with NetEdit3
« Reply #2 on: August 12, 2014, 04:03:26 PM »
This error means the booter in your H4-EBC is too old to recognize the "go-to-booter" command coming from NetEdit3. There are two possible solutions:

- Use NetEdit v2.x or earlier to update the booter for your device, or...
- Download the attached copy of the command-line program called ETHER32.EXE to update the booter for your device.
     - Your H4-EBC firmware/booter files are in c:\HAPTools\Images\H4-EBC folder on your PC.
     - Therefore, it is best to unzip the attached file to that folder.
     - In the ZIP file there are 3 files:
          1. ether32.ex_ - This is the latest Ether32 program. Rename it from .ex_ to .exe for it to work
          2. ether32_2_1.ex_ - This is an older Ether32 in case the latest one doesn't work. Rename it as well and use in the same manner.
          3. ether32.txt - This is a text file explaining how to use Ether32.
There are two types of people in the world; those that can extrapolate from incomplete data sets.

hirzel

  • Newbie
  • *
  • Posts: 8
Re: Cannot update Bootloader with NetEdit3
« Reply #3 on: August 13, 2014, 08:48:33 AM »
YYYEEESSS   - Tnks - it worked.

I tried ether32.exe first, it gave me an error "RAM Allocation Error".  I then tried the ether32_2_1.exe and it worked.

I then went back in with NetEdit3 and it showed up OK with the new bootloader.  I  was then able to update firmware using NetEdit3.

Thanks, Your a life saver. I'll try the EBC in a working I/O system later today to verify its working.

John